Back to overview
Resolved
Email notifications is degraded
Aug 13, 2026 at 12:18pm UTC
Affected services
Email notifications
Resolved
Aug 13, 2026 at 12:26pm UTC
Email notifications recovered.
Affected services
Created
Aug 13, 2026 at 12:18pm UTC
Email notifications is degraded.
Affected services